The D-Link DGS-1250-28X/E is a stackable smart managed switch designed for users needing robust networking solutions, such as small to medium-sized businesses. With 24 Gigabit Ethernet ports and 10G uplink capability, it provides reliable connectivity and management for your network infrastructure.
Key features
| Dimensions | 440 × 44 × 140 mm |
|---|---|
| Producer product family | Stackable Smart Managed Switch with 10G Uplinks |
| Producer product name | DGS-1250-28X/E |
| Warranty | 60 month(s) |
| Form factor | Rackmountable |
| Switch type | Web managed |
| Gigabit Ethernet (copper) ports quantity | 24 |
| POE | No |
| Predominant port type | 10/100/1000 Mbps (RJ-45) |
All specifications (78)
| Specifications | |
|---|---|
| Producer product family | Stackable Smart Managed Switch with 10G Uplinks |
| Producer product name | DGS-1250-28X/E |
| Warranty | 60 month(s) |
| Design | |
| Form factor | Rackmountable |
| Management features | |
| Switch type | Web managed |
| Ports & interfaces | |
| Gigabit Ethernet (copper) ports quantity | 24 |
| POE | No |
| Predominant port type | 10/100/1000 Mbps (RJ-45) |
| Additional specifications | |
| Switch layer | L3 |
| Quality of Service (QoS) support | Yes |
| Web-based management | Yes |
| ARP inspection | Yes |
| Configuring Location Settings (CLI) | Yes |
| System event log | Yes |
| MIB support | RFC2893, RFC4213, RFC4291, RFC2464, RFC2462, RFC4862, RFC2461, RFC4861, RFC2573, RFC1321, RFC2284, RFC2865, RFC2716, RFC3580, RFC826, RFC2463, RFC4443, RFC792, RFC793, RFC768, RFC791, RFC2389, RFC4113, RFC4022, RFC2618, RFC2674, RFC1398, RFC1643, RFC1650, RFC2358, RFC2665, RFC2021, RFC271, RFC1757, RFC2819, RFC1442, RFC1901, RFC1902, RFC1903, RFC1904, RFC1905, RFC1906, RFC1907, RFC1908, RFC2578, RFC3418, RFC2573, RFC2575, RFC2576, RFC1212, RFC1213, RFC1215, RFC1493, RFC1157, RFC2620, |
| Basic switching RJ-45 Ethernet ports quantity | 24 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| SFP+ module slots quantity | 4 |
| Console port | RJ-45 |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ae, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| 10G support | Yes |
| Copper ethernet cabling technology | 10BASE-T, 100BASE-TX, 1000BASE-T |
| Cable types supported | Cat5, Cat5e |
| Port mirroring | Yes |
| Full duplex | Yes |
| Flow control support | Yes |
| Link aggregation | Yes |
| Broadcast storm control | Yes |
| Auto MDI/MDI-X | Yes |
| Spanning tree protocol | Yes |
| Head-of-line (HOL) blocking | Yes |
| VLAN support | Yes |
| Virtual LAN features | Voice VLAN |
| Number of VLANs | 4094 |
| Fiber ethernet cabling technology | 100BASE-FX, 1000BASE-LHX, 1000BASE-X, 1000BASE‑LX, 1000BASE‑SX, 1000BASE‑ZX |
| Switching capacity | 128 Gbit/s |
| Forwarding rate | 95.24 Mpps |
| MAC address table | 16000 entries |
| Store-and-forward | Yes |
| Static route | Yes |
| Number of static routes | 124 |
| Jumbo frames support | Yes |
| Jumbo frames | 12000 |
| Packet buffer memory | 12 MB |
| DHCP features | DHCP client, DHCP server, DHCP snooping |
| Access Control List (ACL) | Yes |
| Access Control List (ACL) rules | 768 |
| IGMP snooping | Yes |
| Security algorithms | EAP, MD5, PEAP, SSH, SSL/TLS, TTLS |
| Loop protection | Yes |
| IP-MAC-Port binding | Yes |
| Queue scheduling algorithms | Weighted Round Robin (WRR) |
| Multicast support | Yes |
| Rack mounting | Yes |
| Product colour | Black |
| LED indicators | Activity, Link, Power, Speed |
| Electromagnetic compatibility | CE A, VCCI A, FCC A, IC, BSMI |
| Memory type | DDR3-SDRAM |
| Internal memory | 2048 MB |
| Flash memory | 64 MB |
| Noise level | 47.6 dB |
| Firmware upgradeable | Yes |
| Mean time between failures (MTBF) | 743482.45 h |
| Power supply included | Yes |
| AC input voltage | 100 - 240 V |
| Power consumption (max) | 30.6 W |
| Power over Ethernet (PoE) | No |
| Operating temperature (T-T) | -5 - 50 °C |
| Storage temperature (T-T) | -20 - 70 °C |
| Operating relative humidity (H-H) | 0 - 95% |
| Storage relative humidity (H-H) | 0 - 95% |
| Heat dissipation | 104.346 BTU/h |
| Certification | CB, UL, BSMI, CCC |
| Dimensions & weight | |
| Net weight | 1.172 kg |
| Width | 440 mm |
| Depth | 140 mm |
| Height | 44 mm |
| Weight | 3.86 kg |
D-Link DGS-1250-28X/E — Stackable Smart Managed Switch with 10G Uplinks, Web managed, Rackmountable
- Regular price
- €230,63
- Sale price
- €230,63
- Regular price
-
Availability on requestBefore you order and pay, we confirm the item is available, so there are no cancellations or refunds. We reply within 1 business day with the delivery time.See delivery times
Before you order and pay, we confirm the item is available, so there are no cancellations or refunds. We reply within 1 business day with the delivery time.
- Web-based management allows for easy configuration and monitoring of your network.
- Supports Layer 3 switching for efficient data routing between different networks.
- Equipped with 4 SFP+ module slots for flexible uplink options.
- Quality of Service (QoS) support helps prioritize network traffic effectively.
- Port mirroring capability enables monitoring of network traffic for better management.
- Product number
- AR-376792
- Brand
- D-Link
- Manufacturer code
- DGS-1250-28X/E
- Mains power
- 100-240 V
More information
Basic information
- Product number
- AR-376792
- Manufacturer warranty
- 60 months
- Returns
- 30-day returns
- Added to our range
- 19.07.2026
Product codes
- EAN
- 790069467875
Packaging
- Package size
- 440 × 140 × 44 mm*
- Package weight
- 2.93 kg*
* approximate
Sold and shipped by ZOZOZON, Alfieri Grupp OÜ, Estonia
Couldn't load pickup availability